Point to Point Frame Relay in Cisco Packet Tracer

From Wiki

Jump to: navigation, search

Contents


Configuring multiple point to point frame relay connections in Cisco Packet Tracer.


Sample Network

Sample Network

Sample network used for the following configuration.


Layout

The network in this example uses two frame relay clouds to connect a hypothetical Head Office to multiple Branch Offices. I will use OSPF as the routing protocol mainly because there is a little trick to getting OSPF to work over frame relay that may not be obvious.

The switches and workstations have minimal configuration; the workstations have static IP addresses and the switches have only their hostnames set and an IP address for VLAN 1.

The R1 to R6 link will be a PPP connection using CHAP authentication; as the configurations will be slightly different for every router I will show all the routers plus screen shots of the frame relay cloud.


Router R1

Configuring a single point to point frame relay interface involves using three commands in addition to the normal interface configuration commands. They are:

  • encapsulation frame-relay - this effectively switches on frame relay for this interface.
  • frame-relay lmi-type cisco - there are three LMI types that can be used with cisco being the default.
  • frame-relay interface-dlci # - the DLCI number is set with this command.

The ip ospf network broadcast command is used whenever you use OSPF with frame relay; all it does is force the OSPF broadcasts across the frame relay link.

Interface s0/0/1 has be configured with three separate sub-interfaces (or virtual interfaces). This means there is no need for the physical interface except that it must be switched on for frame relay (hence the encapsulation frame-relay command). No IP address (or anything else for that matter) should be set on the physical interface; the rest of the configuration is done on the sub-interfaces.

A couple of things to note: I tend to make the DLCI numbers match the sub-interface numbers to avoid confusion and I haven't bothered setting the LMI type as the default is cisco which I am using throughout anyway.

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R1

R1(config)#int f0/0
R1(config-if)#description LINK TO S1
R1(config-if)#ip address 172.16.0.1 255.255.255.0
R1(config-if)#no shutdown 
R1(config-if)#ex

R1(config)#int s0/0/0
R1(config-if)#description FRAME RELAY LINK TO R2
R1(config-if)#ip address 12.1.1.1 255.255.255.252
R1(config-if)#encapsulation frame-relay 
R1(config-if)#frame-relay lmi-type cisco 
R1(config-if)#frame-relay interface-dlci 16
R1(config-if)#ip ospf network broadcast 
R1(config-if)#no shutdown 
R1(config-if)#ex

R1(config)#int s0/0/1
R1(config-if)#description PHYSICAL FRAME RELAY LINK TO R3 R4 R5
R1(config-if)#encapsulation frame-relay 
R1(config-if)#no shutdown 
R1(config-if)#ex

R1(config-if)#int s0/0/1.20 point-to-point
R1(config-subif)#description FRAME RELAY LINK TO R3
R1(config-subif)#ip address 12.1.1.5 255.255.255.252
R1(config-subif)#frame-relay interface-dlci 20
R1(config-subif)#ip ospf network broadcast 
R1(config-subif)#no shutdown 
R1(config-subif)#ex

R1(config)#int s0/0/1.22 point-to-point 
R1(config-subif)#description FRAME RELAY LINK TO R4
R1(config-subif)#ip address 12.1.1.9 255.255.255.252
R1(config-subif)#frame-relay interface-dlci 22
R1(config-subif)#ip ospf network broadcast 
R1(config-subif)#no shutdown 
R1(config-subif)#ex

R1(config)#int s0/0/1.24 point-to-point 
R1(config-subif)#description FRAME RELAY LINK TO R5
R1(config-subif)#ip address 12.1.1.13 255.255.255.252
R1(config-subif)#frame-relay interface-dlci 24
R1(config-subif)#ip ospf network broadcast 
R1(config-subif)#no shutdown 
R1(config-subif)#ex

R1(config)#int s0/1/1
R1(config-if)#description PPP LINK TO R6
R1(config-if)#ip address 12.1.1.17 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown 
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication chap
R1(config-if)#ex

R1(config)#username R6 password cisco

R1(config)#router ospf 1
R1(config-router)#network 12.1.1.0 0.0.0.3 area 0
R1(config-router)#network 12.1.1.4 0.0.0.3 area 0
R1(config-router)#network 12.1.1.8 0.0.0.3 area 0
R1(config-router)#network 12.1.1.12 0.0.0.3 area 0
R1(config-router)#network 12.1.1.16 0.0.0.3 area 0
R1(config-router)#network 172.16.0.0 0.0.0.255 area 0

R1(config)#

Router R2

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R2

R2(config)#int f0/0
R2(config-if)#description LINK TO S2
R2(config-if)#ip address 10.0.20.1 255.255.255.0
R2(config-if)#no shutdown 
R2(config-if)#ex

R2(config)#int s0/0/0
R2(config-if)#description FRAME RELAY LINK TO R1
R2(config-if)#ip address 12.1.1.2 255.255.255.252
R2(config-if)#encapsulation frame-relay 
R2(config-if)#frame-relay lmi-type cisco
R2(config-if)#frame-relay interface-dlci 18
R2(config-if)#ip ospf network broadcast 
R2(config-if)#no shutdown 
R2(config-if)#ex

R2(config)#router ospf 1
R2(config-router)#network 10.0.20.0 0.0.0.255 area 0
R2(config-router)#network 12.1.1.0 0.0.0.3 area 0
R2(config-router)#ex

R2(config)#

Router R3

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R3

R3(config)#int f0/0
R3(config-if)#description LINK TO S3
R3(config-if)#ip address 10.0.30.1 255.255.255.0
R3(config-if)#no shutdown 
R3(config-if)#ex

R3(config)#int s0/0/0
R3(config-if)#description FRAME RELAY LINK TO R1
R3(config-if)#ip address 12.1.1.6 255.255.255.252
R3(config-if)#encapsulation frame-relay 
R3(config-if)#frame-relay lmi-type cisco
R3(config-if)#frame-relay interface-dlci 20
R3(config-if)#ip ospf network broadcast
R3(config-if)#no shutdown 
R3(config-if)#ex

R3(config)#router ospf 1
R3(config-router)#network 10.0.30.0 0.0.0.255 area 0
R3(config-router)#network 12.1.1.4 0.0.0.3 area 0
R3(config-router)#ex

R3(config)#

Router R4

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R4

R4(config)#int f0/0
R4(config-if)#description LINK TO S4
R4(config-if)#ip address 10.0.40.1 255.255.255.0
R4(config-if)#no shutdown 
R4(config-if)#ex

R4(config)#int s0/0/0
R4(config-if)#description FRAME RELAY LINK TO R1
R4(config-if)#ip address 12.1.1.10 255.255.255.252
R4(config-if)#encapsulation frame-relay 
R4(config-if)#frame-relay lmi-type cisco
R4(config-if)#frame-relay interface-dlci 22
R4(config-if)#ip ospf network broadcast 
R4(config-if)#no shutdown 
R4(config-if)#ex

R4(config)#router ospf 1
R4(config-router)#network 10.0.40.0 0.0.0.255 area 0
R4(config-router)#network 12.1.1.8 0.0.0.3 area 0
R4(config-router)#ex

R4(config)#

Router R5

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R5

R5(config)#int f0/0
R5(config-if)#description LINK TO S5
R5(config-if)#ip address 10.0.50.1 255.255.255.0
R5(config-if)#no shutdown 
R5(config-if)#ex

R5(config)#int s0/0/0
R5(config-if)#description FRAME RELAY LINK TO R1
R5(config-if)#ip address 12.1.1.14 255.255.255.252
R5(config-if)#encapsulation frame-relay 
R5(config-if)#frame-relay lmi-type cisco
R5(config-if)#frame-relay interface-dlci 24
R5(config-if)#ip ospf network broadcast 
R5(config-if)#no shutdown 
R5(config-if)#ex

R5(config)#router ospf 1
R5(config-router)#network 12.1.1.12 0.0.0.3 area 0
R5(config-router)#network 10.0.50.0 0.0.0.255 area 0
R5(config-router)#ex

R5(config)#

Router R6

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname R6

R6(config)#int f0/0
R6(config-if)#description LINK TO S6
R6(config-if)#ip address 172.16.10.1 255.255.255.0
R6(config-if)#no shutdown 
R6(config-if)#ex

R6(config)#int s0/0/0
R6(config-if)#description PPP LINK TO R1
R6(config-if)#ip address 12.1.1.18 255.255.255.252
R6(config-if)#encapsulation ppp
R6(config-if)#ppp authentication chap
R6(config-if)#no shutdown 
R6(config-if)#ex

R6(config)#username R1 password cisco

R6(config)#router ospf 1
R6(config-router)#network 172.16.10.0 0.0.0.255 area 0
R6(config-router)#network 12.1.1.16 0.0.0.3 area 0
R6(config-router)#ex

R6(config)#


Frame Relay Cloud A

This cloud is relatively simple to configure as it has only a single connection - a one-to-one point to point connection. The DLCI numbers are only locally significant to the routers so I have chosen 16 and 18 - but you could use anything really.


Sample Network

This is the Serial 0 interface - note that the DLCI number must match what you have configure at the router interface on R1 that connects to this cloud.


Sample Network

This is the Serial 1 interface - very similar to Serial 0.


Sample Network

To make the frame relay connection select Serial 0 from the left hand side and Serial 1 from the right hand side and click Add.


Frame Relay Cloud B

This cloud is a little more complex as it is a one-to-many connection. Each connection is still a point to point link (as they are each on separate subnets) but we have to set Serial 0 to have three individual interfaces instead of one.


Sample Network

The Serial 0 interface has three distinct connections to each of the interfaces on the other side of the cloud; I have used the same DLCIs for each connection on either side of the cloud to illustrate what is connecting to what.


Sample Network

Each of the other interfaces are similar to Frame Relay Cloud A.


Sample Network


Sample Network


Sample Network

As there are three links we have to add the three Serial 0 connections to their counterparts from Serial 1, Serial 2 and Serial 3.


Return to:

Cisco

Main Page

Personal tools